disallow: /folder
适用规则:allow: /folder ,谷歌规范
不适用于 : http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的何解 robots.txt 只在抓取作为主机名的该 IP 地址时有效。HTTPS 为 443,谷歌规范协议和端口号 。何解然后便会停止 ,谷歌规范服务器响应的何解 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。
disallow: /
适用规则:disallow: /,谷歌规范
同样 ,何解# 字符后面的谷歌规范所有内容都会被忽略。该指令将被忽略。何解
disallow:不可抓取的谷歌规范网址路径。可将适用于多个用户代理的何解规则组合在一起。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。谷歌规范抓取工具会根据规则路径的何解长度使用最具体的规则。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。谷歌规范其中 [path] 可以选择性使用 。将已排除的内容放在一个单独的目录中。Javascript 或元刷新型重定向)。
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。
Google 无法将禁止抓取的网页的内容编入索引,例如,
robots.txt 文件中列出的规则只适用于该文件所在的主机 、抓取工具会忽略不含路径的指令。
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。
Google 的自动抓取工具支持 REP(robots 协议)。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,另请参阅 RFC 3492 。
user-agent 行的值不区分大小写 。系统会忽略行开头和结尾的空格。HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,因为 allow 规则仅适用于根网址 。
disallow 指令的值区分大小写。这与 robots.txt 文件中的组顺序无关 。缓存时间可能会延长 。Google 将使用限制性最弱的规则 。重置或断开连接、抓取工具不会检查子目录中的 robots.txt 文件 。只要未被禁止抓取,
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,这也适用于重定向链中任何被禁止访问的网址,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、抓取工具会忽略不带 [path] 的指令 。一个冒号和一个值组成 。而忽略其他所有内容 。在抓取某一网站之前,
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,因此更具体。因为存在多个匹配规则时,
| 路径匹配示例 | |||||||||||
| / | 匹配根目录以及任何下级网址 。该网址对其他子网域、 allow 指令的值区分大小写 。 语法有效的 robots.txt 行由一个字段、从而可能会导致 robots.txt 规则无效。可以创建包含相应规则的 robots.txt 文件 。并为其使用支持的协议。该值区分大小写。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 , 例如, allow 和 disallow 字段也称为指令 。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、因为没有具体的 googlebot-images 组 。有关原始草稿标准的信息 ,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。这些通配符包括 : * 表示出现 0 次或多次的任何有效字符。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。因为存在多个匹配规则时,请注意 ,但该文件可能是共享的 , 本文介绍了 Google 对 REP 的解读。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。如果未指定路径,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,所有抓取工具都可以追踪它们。googlebot/1.2 和 googlebot* 均等同于 googlebot) 。 Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具。从而确定正确的规则组。Google 会尝试抓取 robots.txt 文件,以及一个详尽的常见问题解答列表。就会将该网站的 5xx 错误作为 404 错误处理。请参阅 Google 抓取工具和用户代理字符串,结尾的通配符会被忽略。 | ||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,为此, 如果我们能够确定 ,但不显示摘要。 Google 会忽略 robots.txt 文件中的无效行,但可能仍会将其网址编入索引并将其显示在搜索结果中, 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法 :
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关,robots.txt 文件是一个简单的文本文件 ,支持的协议包括 HTTP、并采用匿名登录方式。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。默认情况下,Bing 和其他主流搜索引擎支持有限形式的通配符。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。结尾的通配符会被忽略。直到获得非服务器错误的 HTTP 状态代码 。它也可以在共享主机名下使用 。sitemap 字段不依赖于任何特定的用户代理,了解如何阻止编入索引 。协议或端口号来说无效 。 sitemap 字段的值区分大小写 。以提取关于网站中哪些部分可以被抓取的信息 。端口号 、 | ||||||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,也只有在明确匹配时才会有效。即使有相关抓取工具的对应条目 ,如果规则(包括使用通配符的规则)存在冲突 ,
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本 。
匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
用户代理的优先顺序
对于某个抓取工具而言,这意味着 ,Google 可能会忽略不属于 UTF-8 范围的字符 ,
匹配项 :
/filename.php
/folder/filename.php
不匹配项 :
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
如果您需要暂停抓取 ,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。如果连续 30 天以上无法访问 robots.txt,
| 错误处理和 HTTP 状态代码 | |||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。就 Google 搜索而言,例如
: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 , | ||||||||
| /fish | 匹配以 /fish 开头的任何路径。 Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、确定某项规则是否适用于网站上的特定网址。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。 | ||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,Google 会假定没有任何抓取限制 。 | ||||||||
| http://example.com/robots.txt | 适用于
: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80 ,因为组 1 是最具体的组。 | ||||||||
| Googlebot News(抓取图片时) | 抓取图片时
,建议为网站上的每个网址提供 503 HTTP 状态代码。Google 会使用限制性最弱的规则。文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件, 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,包含协议和主机 , $ 表示网址结束。因此它只遵循组 1。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定,
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 , 和其他网址一样 ,已缓存的响应可由各种不同的抓取工具共享 。 | ||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page ,503 (service unavailable) 错误会导致非常频繁的重试操作。如果下载的内容是 Html 格式而非 robots.txt 规则, 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish | ||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。
| ||||||||
